get-pip.py 다운로드

get-pip.py 사용자가 아직 없는 파이썬 환경에서 핍, 설치 도구 및 휠을 설치할 수 있는 부트스트래핑 스크립트입니다. 이 리포지토리에 있는 파일을 직접 참조해서는 안 되며 대신 https://bootstrap.pypa.io/ 있는 버전을 사용해야 합니다. 같은 폴더 또는 선택한 다른 폴더에 get-pip.py 다운로드합니다. 나는 당신이 python.exe 파일을 가지고에서 동일한 폴더에 다운로드하고 최신 파이썬 다운로드이 명령을 실행할 것이라고 가정 – 나는 윈도우에 파이썬 3.6이 있다. 당신은 당신이 필요로하는 모든 것을 궁금해 할 필요가 없습니다, 나는 그것을 수행하는 방법을 보여줍니다 숨을. get-pip.py 다운로드하여 .txt가 아닌 .py 파일로 저장하도록 주의하십시오. 그런 다음 명령 프롬프트에서 실행합니다: pip가 설치되었는지 여부를 확인하는 방법입니다. 드문 경우지만 설치되지 않은 경우 get-pip.py 파일을 다운로드하고 리눅스 배포판이 이미 설치된 파이썬과 함께 온 것처럼 파이썬으로 실행하면 시스템의 패키지 관리자를 사용하여 PIP를 설치할 수 있어야합니다. Python의 시스템 설치 버전이 Windows 및 Mac에서 사용되는 get-pip.py 스크립트와 잘 재생되지 않으므로 이 문제가 바람직합니다. get-pip.py 작품의 대부분은 그 안에 번들로 제공되는 핍의 사본에서 온다. 그러나 template.py 내부에 있는 접착제 코드는 get-pip.py 실제로 작동할 수 있도록 합니다.

pip v1.5.1부터 get-pip.py 설치 도구를 먼저 설치해야 하는 것을 중단했습니다. 2) 파이썬 3.4 아래의 버전을 실행중이거나 어떤 이유로 파이썬 3.4와 함께 pip를 설치하지 않은 경우 get-pip.py pip의 공식 설치 스크립트를 사용할 것입니다. pip 설치 프로그램은 이제 당신을 위해 설치 도구를 잡아, 아키텍처에 관계없이 작동 (32 비트 또는 64 비트). 운영 체제 또는 다른 패키지 관리자가 관리하는 Python 설치를 사용하는 경우 주의해야 합니다. get-pip.py 이러한 도구와 조정하지 않으며 시스템이 일관되지 않은 상태로 유지될 수 있습니다. 그것은 핍을 설치합니다. Setuptools가 아직 설치되어 있지 않은 경우, get-pip.py 당신을 위해 그것을 설치합니다. 다음은 파이썬 2.7에 대한 작동합니다. 이 스크립트를 저장하고 실행 : https://raw.github.com/pypa/pip/master/contrib/get-pip.py 핍이 설치되어 있습니다, 다음 환경에 경로를 추가 : 다음 get-pip.py 다운로드 한 폴더에서 다음 명령을 실행 : get-pip.py 또한 설치 설정 도구 2 그리고 휠그들은 아직없는 경우. 설치 도구는 소스 배포판을 설치하는 데 필요합니다. 휠 캐시를 구축하려면 둘 다 필요하지만(설치 속도가 향상됨) 미리 제작된 휠을 설치할 필요는 없습니다. 이러한 패키지를 직접 다운로드, 설치 및 관리하는 것은 실망스럽고 시간이 많이 소요될 수 있습니다.

많은 파이썬 개발자가 모든 것을 훨씬 쉽고 빠르게 만들기 위해 파이썬 (또는 파이썬 PIP)이라는 특수 도구에 의존하는 이유입니다. pip를 설치하려면 이 링크를 따라 get-pip.py get-pip.py. 또는 컬 사용: ez_setup.py를 다운로드하고 실행; 적절한 .egg 파일을 다운로드하여 설치합니다. (현재 제공된 .exe installer는 distutils 설치 관리자 호환성 문제로 인해 Windows용 파이썬의 64비트 버전을 지원하지 않습니다. get-pip.py pip 설치 옵션 및 일반 옵션을 허용합니다. 다음은 몇 가지 예입니다: pip 개발자는 –사용자를 모든 설치에 대 한 기본을 고려 하 고, 핍의 get-pip.py 설치를 포함 하 여, 하지만이 시간에, –사용자 pip 자체에 대 한 설치, 완전히 테스트 또는 승인 간주 되지 않아야. 토론은 문제 1668을 참조하십시오. pip를 설치하거나 업그레이드하려면 get-pip.py 안전하게 다운로드하십시오.